Stucked at bottleneck (installation)

Forum for you who has PHP installation issues

Moderators: egami, macek, gesf

Post Reply
User avatar
Joan Garnet
Moderator
Moderator
Posts: 387
Joined: Sat Aug 03, 2002 2:56 am
Location: Mars
Contact:

Sun Dec 22, 2002 1:28 pm

Edit your PHP.INI file in the Windows directory:
The semicolon in front of cgi.force_redirect=0 must be missing! This 'uncomments' the line and enables the feature, which in this case sets cgi.force_redirect to false.

Something like this -->

Code: Select all

; cgi.force_redirect = 1
cgi.force_redirect=0


Byes
;)

User avatar
WiZARD
Moderator
Moderator
Posts: 1240
Joined: Thu Jun 20, 2002 10:14 pm
Location: Ukraine, Crimea, Simferopol
Contact:

Mon Dec 23, 2002 12:46 am

Or try set PHP like Module not like CGI
"Sex,Drugs and Rock&Roll " replaced at "Sucks,Bugs and Plug&Play";
Image

User avatar
Joan Garnet
Moderator
Moderator
Posts: 387
Joined: Sat Aug 03, 2002 2:56 am
Location: Mars
Contact:

Mon Dec 23, 2002 4:39 am

; cgi.force_redirect is necessary to provide security running PHP as a CGI under
; most web servers. Left undefined, PHP turns this on by default.

So you've got it by default now, nothing's changed yet.

What you should do is left it like this -->

Code: Select all

; cgi.force_redirect = 1
cgi.force_redirect = 0

As you see I add a line setting it to false.
P.D. Try to stop Apache service while changing things.

Try it.
I hope it'll work fine, otherwise you'll have to download the CGI module for Apache at http://www.php.net/downloads.php

User avatar
WiZARD
Moderator
Moderator
Posts: 1240
Joined: Thu Jun 20, 2002 10:14 pm
Location: Ukraine, Crimea, Simferopol
Contact:

Wed Dec 25, 2002 12:08 am

I'm propose install PHP Like module (in Winows or UNIX)
cause it's faster and not have more problem....
"Sex,Drugs and Rock&Roll " replaced at "Sucks,Bugs and Plug&Play";
Image

Post Reply
  • Information
  • Who is online

    Users browsing this forum: Bing [Bot] and 0 guests