problems connecting to MYSQL, from PHP on Apache2(winxp)

Installation and configuration iussues

Moderators: gesf, Michalio

Post Reply
User avatar
Alexej Kubarev
php-forum GURU
php-forum GURU
Posts: 2213
Joined: Fri Mar 05, 2004 7:15 am
Location: Täby, Stockholms län
Contact:

You HAVE to use mysqli to connect to mysql 5
That means that you HAVE to use php5 as well..
Best Regards,
Alexej Kubarev
-------------------------------
Zend Certified Engineer
Image Image
firosit

Hello
U can use BigApche/Xampp if u r working under windows
Installation and working is very easy
User avatar
Alexej Kubarev
php-forum GURU
php-forum GURU
Posts: 2213
Joined: Fri Mar 05, 2004 7:15 am
Location: Täby, Stockholms län
Contact:

not so flexible and so on.
easiest way is actually installing everything yourself
PHP4.4 and Mysql 5 are not compatible and there is NO way you will connect to it.. you need mysqli for that and its only available with php5 / php5.1
Best Regards,
Alexej Kubarev
-------------------------------
Zend Certified Engineer
Image Image
firosit

Thank You for your valuble information
Leviatas

I am having a similar problem... I am using Apache 2.2.4 PHP 5.2.2 and MySQL 5.0 These should be compatible, but whenever I put the mysql files in place, my ()phpinfo comes up blank...
Post Reply