Installing PHP and its dependencies

Forum for you who has PHP installation issues

Moderators: egami, macek, gesf

Post Reply
anaigini45
New php-forum User
New php-forum User
Posts: 4
Joined: Thu Jan 30, 2020 7:13 am

Thu May 14, 2020 3:39 am

Hi,

I need to install PHP for an application to run. These are the PHP extensions needed as pre-requisites:
gd : 2.0 or later PHP GD extension must support PNG images (--with-png-dir), JPEG (--with-jpeg-dir) images and FreeType 2 (--with-freetype-dir).
bcmath : php-bcmath (--enable-bcmath)
ctype : php-ctype (--enable-ctype)
libXML : 2.6.15 or later php-xml or php5-dom, if provided as a separate package by the distributor.
xmlreader : php-xmlreader, if provided as a separate package by the distributor.
xmlwriter : php-xmlwriter, if provided as a separate package by the distributor.
session : php-session, if provided as a separate package by the distributor.
sockets : php-net-socket (--enable-sockets). Required for user script support.
mbstring : php-mbstring (--enable-mbstring)
gettext : php-gettext (--with-gettext). Required for translations to work.
ldap : php-ldap. Required only if LDAP authentication is used in the frontend.
ibm_db2 : Required if IBM DB2 is used as Zabbix backend database.
mysqli : Required if MySQL is used as Zabbix backend database.
oci8 : Required if Oracle is used as Zabbix backend database.
pgsql : Required if PostgreSQL is used as Zabbix backend database.
I managed to install all needed, except php-net-socket (It says php-net-socket not found). How do I resolve this?

And I have installed php using the method package install, not from source. Do I still need to install the php extensions above that have (--enable) in them?

And what about if I use the CentOS/RedHat ScLO repository? Is there a substitute for any of the packages above or is it still the same name? The version of CentOS I am using is CentOS 7, and prefer to use SCLO to get the latest packages.

Cheers.
User avatar
hyper
php-forum GURU
php-forum GURU
Posts: 1190
Joined: Mon Feb 22, 2016 5:52 pm

Thu May 14, 2020 7:45 am

Try looking for php-net-socket on the CentOS site, it's probably called something else.
Post Reply