php-iconv will not install, or cannot be found

Ask about general coding issues or problems here.

Moderators: egami, macek, gesf

Post Reply
walterbyrd
New php-forum User
New php-forum User
Posts: 1
Joined: Wed Jan 20, 2021 2:54 pm

Wed Jan 20, 2021 3:07 pm

I am trying to install Moodle on Ubuntu. I keep getting this error:
Moodle requires the iconv PHP extension. Please install or enable the iconv extension.
When I try to install php-iconv, I get this:

Code: Select all

# apt install php-iconv
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'php7.4-common' instead of 'php-iconv'
php7.4-common is already the newest version (7.4.3-4ubuntu2.4).
Post Reply