Board index   FAQ   Search  
Register  Login
Board index php forum :: Database MySQL Installation

Can't connect to MySQL

Installation and configuration iussues

Moderators: macek, egami, gesf

Can't connect to MySQL

Postby Pablo1234 » Mon Jun 09, 2003 8:52 am

I have been using MySQL for 2 years now and I have never seen this problem before.
Win2K, IIS 5, MySQL 4.0.13 win
I have just recently reinstalled my whole system and now all of the sudden I can not conect to my new install of MySQL. I can create Databases and stuff from the command line, but I can not connect to my server. I am doing nothing difrent than before. This is my ini file, all sensitive stuff is * out:

[mysqld]
basedir=C:/mysql
#bind-address=65.30.221.127
datadir=C:/mysql/data
#language=C:/mysql/share/your language directory
#slow query log#=
#tmpdir#=
#port=3306
#set-variable=key_buffer=16M
[WinMySQLadmin]
Server=*:/mysql/bin/mysqld-nt.exe
user=**********
password=**********

I am not sure wher to start but I have tryed to connect with localhost, 127.0.0.1, http://www.rtspc.com, 65.30.221.127 but none work. this is a sample of my err file:
030609 9:55:43 InnoDB: Started
MySql: ready for connections.
Version: '4.0.13-nt' socket: '' port: 3306
030609 11:19:53 MySql: Normal shutdown

030609 11:19:53 InnoDB: Starting shutdown...
030609 11:19:55 InnoDB: Shutdown completed
030609 11:19:55 MySql: Shutdown Complete

then I run mysqladmin version
Server version 4.0.13-nt
Protocol version 10
Connection localhost via TCP/IP
TCP port 3306
Uptime: 2 hours 6 min 4 sec

Threads: 2 Questions: 680 Slow queries: 0 Opens: 7 Flush tables: 1 Open tab
les: 0 Queries per second avg: 0.090

Any sugetions?
Pablo1234
New php-forum User
New php-forum User
 
Posts: 2
Joined: Mon Jun 09, 2003 8:00 am

Re: Can't connect to MySQL

Postby WiZARD » Mon Jun 09, 2003 11:28 pm

i dont know but at local computer i'm not use it file.....
User avatar
WiZARD
Moderator
Moderator
 
Posts: 1257
Joined: Thu Jun 20, 2002 10:14 pm
Location: Ukraine, Crimea, Simferopol

Postby Pablo1234 » Sat Jul 12, 2003 6:30 am

I am not sure why it did not work the first time but try using a blank password. For some resson it did not have one even though it was in my.ini, check you my ini for errors ect.
Pablo1234
New php-forum User
New php-forum User
 
Posts: 2
Joined: Mon Jun 09, 2003 8:00 am

Postby sigix » Thu Jul 31, 2003 3:35 am

these errors usualy occur when mysqld ,httpd are not running
could not connect to localhost(port) means no one is listening at that port for your connection.
also see whether your username and password are required for your connection (in configuration file mysql.password=..,mysql.username=... and ServerName=...)
settings...
sigix
php-forum Active User
php-forum Active User
 
Posts: 364
Joined: Mon Jul 14, 2003 9:39 pm
Location: /Earth/Xion

Postby Redcircle » Thu Jul 31, 2003 11:14 pm

have you run mysqld --install to install it as a service and run the service?
User avatar
Redcircle
Moderator
Moderator
 
Posts: 830
Joined: Tue Jan 21, 2003 10:42 pm
Location: Michigan USA


Return to MySQL Installation

Who is online

Users browsing this forum: No registered users and 1 guest

Sponsored by Sitebuilder Web hosting and Traduzioni Italiano Rumeno and antispam for cPanel.

cron