Mail doesn't work after changing SMTP server

the mail() function

Moderators: macek, egami, gesf

Laura Croft
New php-forum User
New php-forum User
Posts: 5
Joined: Fri Mar 07, 2003 1:00 am

Mail doesn't work after changing SMTP server

Postby Laura Croft » Fri Mar 07, 2003 1:48 am

I use W2k and the mail() function was working perfectly till my company's internet provider changed the mail servers.

I was using teleca.es and now i use smtp.teleca.es as SMTP server. Just by changing that the mail() doesn't work and I can't understand why (I change the php.ini file).

Does any of you have a clue?

Thanks.

User avatar
Oleg Butuzov
Last Samuray
Last Samuray
Posts: 831
Joined: Sun Jun 02, 2002 3:09 am

Postby Oleg Butuzov » Mon Mar 10, 2003 2:20 am

some smpt servers can sent mail just from own server users.
for exemple smtp.mail.ru can send only email that containe mail.ru for (ex deviant@mail.ru)

Laura Croft
New php-forum User
New php-forum User
Posts: 5
Joined: Fri Mar 07, 2003 1:00 am

Postby Laura Croft » Mon Mar 10, 2003 2:53 am

Well, thanks but that doesn't help me.

I send the emails from webmaster@teleca.es and since the smtp server is smtp.teleca.es it should work (as it did before).

Any other suggestion?

Jeremy
New php-forum User
New php-forum User
Posts: 3
Joined: Wed Dec 17, 2003 3:44 am
Contact:

Postby Jeremy » Wed Dec 17, 2003 7:44 am

Check the smtp configuration. It may be that Pop before smtp is set so you are required to be logged into the pop3 server first. It is also possible that force smtp auth is set. then you have to login before you can send

Jeremy


Return to “PHP coding => Mail”

Who is online

Users browsing this forum: No registered users and 0 guests