Board index   FAQ   Search  
Register  Login
Board index PHP PHP General

php and a blank page

General discussions related to php

Moderators: macek, egami, gesf

php and a blank page

Postby nexus14 » Fri Feb 07, 2003 4:13 pm

hi all, i am new here so i appoligise if this is an easy solve.
I have latest php, apache, mysql and my admin, i have two good, books and done all the installations. php info test works fine, printing a simple echo "hello" works, connection to my sql works, i have even got it to work with xhtml encoding.
My problem occurs when i do something else, a simple form for example or a cookie, even if i dont access mysql in anyway also - on loading a page i get nothing, a blank interent explorer, no errors, just notta thing.
And sometime it wants me to download the page instead - ahh help.
More info:
I have Windows Xp Pro, and my head hurts
Thanks
nexus14
New php-forum User
New php-forum User
 
Posts: 3
Joined: Fri Feb 07, 2003 3:55 pm
Location: leicester

Blank pages

Postby greg » Fri Feb 07, 2003 9:23 pm

When I get blank pages without any errors, I have a syntax error somewhere. Sometimes they are very hard to find. It drives me crazy that I get no error.

Not sure what is happening to you but maybe it is a simple error. Debugging can be a pain.
greg
New php-forum User
New php-forum User
 
Posts: 11
Joined: Wed Nov 13, 2002 6:56 am

Re: Blank pages

Postby *JaH* » Fri Feb 14, 2003 4:27 pm

greg wrote:When I get blank pages without any errors, I have a syntax error somewhere. Sometimes they are very hard to find. It drives me crazy that I get no error.

Not sure what is happening to you but maybe it is a simple error. Debugging can be a pain.


You can set in yur php.ini which level of errors to show, if you wanna see all the errors onscreen change it.....otherwise, look in your error.log....all errors are logged :)

Still debugging is a pain, yur right about that ....dzsoft php editor helps me out alot though :D
*JaH*
New php-forum User
New php-forum User
 
Posts: 80
Joined: Fri Jan 31, 2003 4:18 pm

Postby Redcircle » Sat Feb 15, 2003 10:44 am

I have Windows Xp Pro, and my head hurts


There is a bug with window XP that causes this very problem. make sure you run all the updates for windowsXP. I can't remember if the bug was with apache or PHP.
User avatar
Redcircle
Moderator
Moderator
 
Posts: 830
Joined: Tue Jan 21, 2003 10:42 pm
Location: Michigan USA


Return to PHP General

Who is online

Users browsing this forum: No registered users and 1 guest

Sponsored by Sitebuilder Web hosting and Traduzioni Italiano Rumeno and antispam for cPanel.

cron