PHP 5.5.4 compatibility with CentOS 6.4

Forum for you who has PHP installation issues

Moderators: macek, egami, gesf

TheOC2PS
New php-forum User
New php-forum User
Posts: 2
Joined: Fri Sep 27, 2013 3:28 am

PHP 5.5.4 compatibility with CentOS 6.4

Postby TheOC2PS » Fri Sep 27, 2013 3:34 am

PHP wrote:PHP 5.5.4 released
All PHP users are encouraged to upgrade to this new version.


We have PHP 5.5.4 installed on CentOS 6.4 64-bit.

Installing mcrypt is proving to be a major issue.

Getting the error

Code: Select all

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20121212/mcrypt.so' - /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /usr/lib/php/extensions/no-debug-non-zts-20121212/mcrypt.so)


Does this mean that mcrypt needs glibc 2.14 or higher?

If so, that would mean CentOS 6.4 can't run PHP 5.5.4 with mcrypt, and that just seems far-fetched.

CentOS 6.4 comes with PHP 5.3.3 and glibc 2.12

Has either mcrypt or libmcrypt been changed since PHP 5.3.3?

johnj
php-forum Super User
php-forum Super User
Posts: 1805
Joined: Thu Mar 10, 2011 5:07 pm

Re: PHP 5.5.4 compatibility with CentOS 6.4

Postby johnj » Wed Oct 02, 2013 6:27 am

Yes, it is asking for glibc 2.14


Return to “PHP Installation”

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest