PhP browser issues

Forum for you who has PHP installation issues

Moderators: macek, egami, gesf

crazeycane
New php-forum User
New php-forum User
Posts: 2
Joined: Thu May 24, 2012 5:23 pm

PhP browser issues

Postby crazeycane » Thu May 24, 2012 5:54 pm

Hi noob here, I have used php in the past and it worked fine. Now when i try to use php absolutely nothing shows in the browser with a simple echo.
Ex:
<?php
echo "what the heck";
?>
In browser: I get a blank white page.

With more extensive code I get output in the browser but its all wrong
Ex:
<?php

// OK because we escaped the quotes!
echo "<h5 class=\"specialH5\">I love using PHP!</h5>";

// OK because we used an apostrophe '
echo "<h5 class='specialH5'>I love using PHP!</h5>";
?>

In browser: this is what is seen.

I love using PHP!"; // OK because we used an apostrophe ' echo "
I love using PHP!

"; ?>


* I am viewing through localhost and have tried from 127.0.0.1
*I have tried in explorer, chrome , ff, and opera with same results
*I have uninstalled and installed xampp several times successfully,
the only problem i do get from xampp is from the control panel saying i need to start xampp from root directory but. i received that same notice in the past and it worked fine.

Anyone else have this problem or know how to solve this? Any comments is greatly appreciated.

User avatar
Nullsig
php-forum Fan User
php-forum Fan User
Posts: 981
Joined: Thu Feb 17, 2011 6:52 am
Location: Racine, WI

Re: PhP browser issues

Postby Nullsig » Fri May 25, 2012 5:41 am

If the following are true:
-Page resolves but response is blank
-Page has .php extension

Then more than likely your server is not installed correctly or more specifically your PHP packages are not installed correctly.

crazeycane
New php-forum User
New php-forum User
Posts: 2
Joined: Thu May 24, 2012 5:23 pm

Re: PhP browser issues

Postby crazeycane » Fri May 25, 2012 11:14 am

yes both are true,
I have uninstalled and re installed several times.
Each time successful and still the same problem, this truly have me tumped


Return to “PHP Installation”

Who is online

Users browsing this forum: No registered users and 2 guests