Have 5.2.1 in stalled, need 5.3 as well

Forum for you who has PHP installation issues

Moderators: macek, egami, gesf

pzh20
New php-forum User
New php-forum User
Posts: 1
Joined: Mon Sep 19, 2011 6:20 am

Have 5.2.1 in stalled, need 5.3 as well

Postby pzh20 » Mon Sep 19, 2011 9:32 am

I run 5.2.1 on my windows server under IIS6 already, but need to install the latest version for Word Press etc., but must be sure it does not impact other sites on the same server.

How can I install and run 2 version at once without impacting eachother?

manyt hanks
Pete

FishBird
New php-forum User
New php-forum User
Posts: 21
Joined: Thu Apr 12, 2012 8:05 am
Contact:

Re: Have 5.2.1 in stalled, need 5.3 as well

Postby FishBird » Thu Apr 12, 2012 11:40 am

You can simply compile php in another prefix like this:

./configure --prefix=/var/lib/phpVersions/php-5.2.17 --with-config-file-path=/var/lib/phpVersions/php-5.2.17/etc/ --with-config-file-scan-dir=/var/lib/phpVersions/php-5.2.17/php.d [ your other options ]

and configure apache, nginx or so to use that prefix for .php5 files or so.


Return to “PHP Installation”

Who is online

Users browsing this forum: No registered users and 1 guest

cron