OpenSSL Windows binaries

Forum for you who has PHP installation issues

Moderators: macek, egami, gesf

lvedin
New php-forum User
New php-forum User
Posts: 5
Joined: Fri Apr 15, 2011 3:06 am

OpenSSL Windows binaries

Postby lvedin » Fri Apr 15, 2011 3:52 am

PHP.net: "To use PHP's OpenSSL support you must also compile PHP --with-openssl[=DIR]"

But what about the Windows binaries, are they compiled with openssl or do I must to compile my self to use SSL ?

REF Windows binaries: http://windows.php.net/download/ -> VC6 x86 Thread Safe (2011-Mar-22 13:29:30)

( I have try SSL and to configure for SSL, but never get it listed in phpinfo(), so I figure if its not compiled or if I'm not able to configure )

Thanks !

johnj
php-forum Super User
php-forum Super User
Posts: 1805
Joined: Thu Mar 10, 2011 5:07 pm

Re: OpenSSL Windows binaries

Postby johnj » Fri Apr 15, 2011 9:01 am

did u try VC9?

lvedin
New php-forum User
New php-forum User
Posts: 5
Joined: Fri Apr 15, 2011 3:06 am

Re: OpenSSL Windows binaries

Postby lvedin » Fri Apr 15, 2011 9:59 pm

Thanks for reply.

PHP.net: "Do NOT use VC9 version with apache.org binaries"

I do use apache.org binaries. I can try anything required, but primary first I would like to know if the binaries Apache + PHP does support SSL.

The Apache say it support OpelSSL: http://httpd.apache.org/download.cgi "Win32 Binary including OpenSSL 0.9.8o (MSI Installer):"

So the issue seams to be ether PHP-binaries or my Apache/PHP -config. A file php_openssl.dll is included under PHP/ext in the zip "VC6 x86 Thread Safe (2011-Mar-22 13:29:30)". I have try many different install/config suggests by chance from google but i do have not get it to work.

johnj
php-forum Super User
php-forum Super User
Posts: 1805
Joined: Thu Mar 10, 2011 5:07 pm

Re: OpenSSL Windows binaries

Postby johnj » Fri Apr 15, 2011 10:23 pm

I tested using apache (httpd-2.2.17-win32-x86-openssl-0.9.8o) and php-5.3.6-Win32-VC9-x86....it is working.

johnj
php-forum Super User
php-forum Super User
Posts: 1805
Joined: Thu Mar 10, 2011 5:07 pm

Re: OpenSSL Windows binaries

Postby johnj » Fri Apr 15, 2011 10:25 pm

You better run a VM with some linux flavor on your windows machine.

lvedin
New php-forum User
New php-forum User
Posts: 5
Joined: Fri Apr 15, 2011 3:06 am

Re: OpenSSL Windows binaries

Postby lvedin » Sat Apr 16, 2011 2:39 am

johnj wrote:I tested using apache (httpd-2.2.17-win32-x86-openssl-0.9.8o) and php-5.3.6-Win32-VC9-x86....it is working.
Ok, i'll try that.

EDIT:
Tried, now phpinfo() display SSL as "OpenSSL support disabled (install ext/openssl)" :) .

I may just need to enable SSL.

EDIT #2:
:D :D :D
Now it works, I just enabled OpenSSL by add the lines php.ini

[PHP_OPENSSL]
extension=php_openssl.dll

And then copied php_openssl.dll from the ext-folder, to directly under the PHP-folder, restaring Apache.

Thanks a lot !

rca63
New php-forum User
New php-forum User
Posts: 2
Joined: Thu Jul 14, 2011 7:35 pm

Re: OpenSSL Windows binaries

Postby rca63 » Mon Aug 15, 2011 12:15 am

May I ask for your help? I had problem with php.openssl.dll not showing up when I ran phpinfo(), thanks

I use my notebook as server, running php v5.2.1, try to send email with mail function.
I download the sendmail.zip, but I do not know what path should I put the sendmail.exe
Now I have the folder sendmail inside Windows, can't see it is working.
I have my php source code in C:\AppServ\www\phptest2\testing2\aah.php ,
I do not have \usr\lib, as suggested by php.net

I can see the php-openssl.dll in windows, but when run the phpinfo(), it don't show up,
I also set the php.ini file, thanks for the help.


Return to “PHP Installation”

Who is online

Users browsing this forum: No registered users and 0 guests

cron