HELP! file_exists function can't find Perl!

Discuss server installationa nd configuration issues here

Moderators: macek, egami, gesf

New php-forum User
New php-forum User
Posts: 1
Joined: Fri Jan 28, 2011 8:00 pm

HELP! file_exists function can't find Perl!

Postby reepicheep » Fri Jan 28, 2011 8:17 pm

Perl is in usr/bin/perl on my server, but the PHP file_exists function returns "false" for /usr/bin/perl. I can execute Perl commands, but our PHP shopping cart thinks Perl is missing.

PHP safe mode is off. I even tried turning it on and off again, no change. I set open_basedir = /usr/bin, still no change.

Perl has read and execute permissions. I've searched the php.ini for clues but can't find anything.

This test script shows the results of the "file_exists" function (for /usr/bin/perl) and "perl -v":

Server is Apache 2.0 with PHP 5.1.6. phpinfo shows 18 additional .ini files parsed besides php.ini. Those are part of a default configuration and I have not looked at all of them, only php.ini.

I have been working on this for weeks, I'm out of ideas, and nearly losing my mind. Can anyone suggest *any* setting to check or any experiment to try? :help:

Return to “Server installation and configuration”

Who is online

Users browsing this forum: No registered users and 2 guests