Where is my "document root"?

Forum for you who has PHP installation issues

Moderators: macek, egami, gesf

lwalper
New php-forum User
New php-forum User
Posts: 9
Joined: Fri Aug 06, 2010 9:56 am

Where is my "document root"?

Postby lwalper » Wed Aug 25, 2010 10:31 am

I've read quite a bit, but for some reason am having trouble figuring out where my "document root" is located.

I looked in the file "httpd.conf" and it tells me that the server root is located at "C:/xampp/apache"

So I created a folder and simple PHP file in that folder. The folder is located at file:///C:/xampp/apache/php_practice/hello.php which I browse to from within my browser. The HTML reads OK, but there's no PHP text showing.

I have the xampp control panel open and it looks like Apache is running, MySql is also running. Am I not looking/working in the right folder?

lwalper
New php-forum User
New php-forum User
Posts: 9
Joined: Fri Aug 06, 2010 9:56 am

Re: Where is my "document root"?

Postby lwalper » Wed Aug 25, 2010 11:43 am

Maybe my coding is bad - it's a little snippet I got off a PHP "learning" site:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head></head>
<body>

Agent: So who do you think you are, anyhow?
<br>

<?php
// print output
echo "Neo: I am Neo, but my people call me The One.";
?>

</body>
</html>

lwalper
New php-forum User
New php-forum User
Posts: 9
Joined: Fri Aug 06, 2010 9:56 am

Re: Where is my "document root"?

Postby lwalper » Thu Aug 26, 2010 5:43 am

This may be the wrong area to post, but I'm having difficulty locating information about the Apache installation. At the Apache site it indicates that there is an active Apache community, but so far I've been unable to find a forum that deals with Apache. If someone has a link I'd appreciate it.

lwalper
New php-forum User
New php-forum User
Posts: 9
Joined: Fri Aug 06, 2010 9:56 am

Re: Where is my "document root"?

Postby lwalper » Thu Aug 26, 2010 10:06 am

Fixed the problem ...

Uninstalled and deleted Xampp. Installed EasyPHP which came with better instructions.


Return to “PHP Installation”

Who is online

Users browsing this forum: No registered users and 0 guests