I Just Can't Complete the phpmyadmin Installation Properly..

How to use phpmyadmin.... phpmyadmin related arguments. Even phpMyAdmin issues

Moderators: macek, egami, gesf

abrogard
New php-forum User
New php-forum User
Posts: 7
Joined: Sat Oct 14, 2006 2:25 am

I Just Can't Complete the phpmyadmin Installation Properly..

Postby abrogard » Sat Oct 14, 2006 2:30 am

Hi...

I'm running IIS on my winxp machine in order to test my sites before uploading them.

I've downloaded and installed Mysql. I've downloaded and installed PHP.

I've downloaded and tried to install phpmyadmin and it all seemed to go well.

But when I try to access my localhose/phpmyadmin/index.php I get an error message that 'Mysql said Access denied' and suggesting it is probably because I need a config file and might want to use the setp script to create one.

But when I click on the 'setup script' I get a page with one welcome and two warnings. One warning says that it 'cannot load or save configuration'
and telling me to create a web server writable dir as described in the documentation.

Well I've done that. But all this is still happening.

I've also created a 'config' directory in the root of phpmyadmin.
I've given the web server (IIS) read/write access to it (I think... via IUSR ?)
I've copied the sample config file over to that directory and renamed it config.php

I DON'T know how to properly edit that file.

This is how it currently looks:


/* $Id: config.sample.inc.php,v 2.1.2.2 2006/08/28 08:14:14 nijel Exp $ */
// vim: expandtab sw=4 ts=4 sts=4:

/**
* phpMyAdmin sample configuration, you can use it as base for
* manual configuration. For easier setup you can use scripts/setup.php
*
* All directives are explained in Documentation.html and on phpMyAdmin
* wiki <http://wiki.cihar.com>.
*/

/*
* This is needed for cookie based authentication to encrypt password in
* cookie
*/
$cfg['blowfish_secret'] = ''; /* YOU MUST FILL IN THIS FOR COOKIE AUTH! */

/*
* Servers configuration
*/
$i = 0;

/*
* First server
*/
$i++;
/* Authentication type */
$cfg['Servers'][$i]['auth_type'] = 'cookie';
/* Server parameters */
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = false;
/* Select mysqli if your server has it */
$cfg['Servers'][$i]['extension'] = 'mysql';
/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pmausr';
$cfg['Servers'][$i]['controlpass'] = 'pmapass';
/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
$cfg['Servers'][$i]['relation'] = 'pma_relation';
$cfg['Servers'][$i]['table_info'] = 'pma_table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma_column_info';
$cfg['Servers'][$i]['history'] = 'pma_history';

/*
* End of servers configuration
*/

/*
* Directories for saving/loading files from server
*/
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';

?>



Can anyone help?

regards,

ab

User avatar
WiZARD
Moderator
Moderator
Posts: 1257
Joined: Thu Jun 20, 2002 10:14 pm
Location: Ukraine, Crimea, Simferopol
Contact:

Re: I Just Can't Complete the phpmyadmin Installation Proper

Postby WiZARD » Tue Nov 07, 2006 1:14 am

try read info about manual phpMyAdmin installing... seems what problem in permission....

abrogard
New php-forum User
New php-forum User
Posts: 7
Joined: Sat Oct 14, 2006 2:25 am

Postby abrogard » Tue Nov 07, 2006 2:17 am

Not real happy with your signature... if you are directing it at all comers you're going to have to be careful what sort of questions you ask yourself, aren't you? A man of your presumably high intellect will appreciate that a question can only be seen as dumb in the light of sufficient knowledge. Failing that knowledge one has no option but to question. Using google is simply the first step in questioning - it brings a list of possible sources. Experience soon teaches that most reliable and rewarding of these sources are forums. Hence one often finishes up in a forum, asking 'dumb questions'.

Thankfully it is very rare - but not at all unknown - that some conceited clot will waste time, space and energy trying to adopt some sort of intellectual high ground and berate the questioner for questioning - while at the same time not providing any answer - when providing the answer would have taken less space, time and energy.

i.e. they are counter productive and doubtless feeding their own egos.

In my own case I named the config file config.php, as I clearly said, and it should, of course, be named config.inc.php, strangely and counter-intuitively enough.

That's all you needed to say. It is not, to my recollection, clearly said in the manual.

regards,

ab :)

User avatar
gesf
Moderator
Moderator
Posts: 1717
Joined: Sun Dec 29, 2002 5:03 am
Location: Portugal / Sweden
Contact:

Postby gesf » Tue Nov 07, 2006 3:24 am

abrogard, don't be ofended with WiZARD's signature!
Like WiZARD said, it must be some "permissions" problem.
Put your phpmyadmin as original (file and folders structure) and than make sure you give the right permissions to main files like your config file.


Return to “phpMyAdmin”

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest