Board index   FAQ   Search  
Register  Login
Board index php forum :: Database phpMyAdmin

Password Problems, Connect Via terminal not via myadmin

How to use phpmyadmin.... phpmyadmin related arguments. Even phpMyAdmin issues

Moderators: macek, egami, gesf

Password Problems, Connect Via terminal not via myadmin

Postby Sharky01276 » Sun Feb 26, 2006 6:12 am

Basically its the title,

After changing my password via phpmyadmin then trying to log on again i got a access denied error. However i can connect fine using this new password via the terminal.

Tried loads of things nothing has worked properly. Any help would be welcomed thanks in advance

Alan
Sharky01276
New php-forum User
New php-forum User
 
Posts: 4
Joined: Sun Feb 26, 2006 6:08 am

Postby Alexej Kubarev » Sun Feb 26, 2006 6:44 am

check if your authenticcation type is not set to config (in config.inc.php )
then there is another thing: did you flush the priviliges? are you sure that you've not changed the host you way be connecting from?
what mysql server version are you running?
User avatar
Alexej Kubarev
Site Admin
Site Admin
 
Posts: 2223
Joined: Fri Mar 05, 2004 7:15 am
Location: Täby, Stockholms län

Postby Sharky01276 » Sun Feb 26, 2006 7:20 am

kk :) Well it was all working, I havnt changed the php-config file. I have flushed the privilages. and the host im coming from is always local host (its running on my home pc)

Here is everything u asked for.

Code: Select all
mysql  Ver 14.12 Distrib 5.0.18, for pc-linux-gnu (i686) using readline 5.0

Connection id:          18
Current database:
Current user:           root@localhost
SSL:                    Not in use
Current pager:          stdout
Using outfile:          ''
Using delimiter:        ;
Server version:         5.0.18-standard
Protocol version:       10
Connection:             Localhost via UNIX socket
Server characterset:    latin1
Db     characterset:    latin1
Client characterset:    latin1
Conn.  characterset:    latin1
UNIX socket:            /var/lib/mysql/mysql.sock
Uptime:                 31 min 47 sec

Threads: 1  Questions: 142  Slow queries: 0  Opens: 0  Flush tables: 1  Open tables: 7  Queries per second avg: 0.074



Code: Select all
$i++;
$cfg['Servers'][$i]['host']          = '127.0.0.1'; // MySQL hostname or IP address
$cfg['Servers'][$i]['port']          = '';          // MySQL port - leave blank for default port
$cfg['Servers'][$i]['socket']        = '';          // Path to the socket - leave blank for default socket
$cfg['Servers'][$i]['connect_type']  = 'tcp';       // How to connect to MySQL server ('tcp' or 'socket')
$cfg['Servers'][$i]['extension']     = 'mysql';     // The php MySQL extension to use ('mysql' or 'mysqli')
$cfg['Servers'][$i]['compress']      = FALSE;       // Use compressed protocol for the MySQL connection
                                                    // (requires PHP >= 4.3.0)
$cfg['Servers'][$i]['controluser']   = '';          // MySQL control user settings
                                                    // (this user must have read-only
$cfg['Servers'][$i]['controlpass']   = '';          // access to the "mysql/user"
                                                    // and "mysql/db" tables).
                                                    // The controluser is also
                                                    // used for all relational
                                                    // features (pmadb)
$cfg['Servers'][$i]['auth_type']     = 'http';    // Authentication method (config, http or cookie based)?
$cfg['Servers'][$i]['user']          = '';      // MySQL user
$cfg['Servers'][$i]['password']      = '';          // MySQL password (only needed
                                                    // with 'config' auth_type


There ya go , Thanks in advance.
Sharky01276
New php-forum User
New php-forum User
 
Posts: 4
Joined: Sun Feb 26, 2006 6:08 am

Postby Alexej Kubarev » Sun Feb 26, 2006 1:09 pm

well, im not sure about the cause of the problem.
however you might neeed to change this line:

$cfg['Servers'][$i]['extension'] = 'mysql';

to

$cfg['Servers'][$i]['extension'] = 'mysqli';

reason: mysqli is needed for propper communication with mysql 5.0

but this shouldnt be the cause of the problem as it worked fine before.
try changing your pass via console and try to login again.
User avatar
Alexej Kubarev
Site Admin
Site Admin
 
Posts: 2223
Joined: Fri Mar 05, 2004 7:15 am
Location: Täby, Stockholms län

Postby Sharky01276 » Sun Feb 26, 2006 1:23 pm

done that many many times :)

still not letting me back in.

Changing to i, made no difference

thanks for your replys!!!
Sharky01276
New php-forum User
New php-forum User
 
Posts: 4
Joined: Sun Feb 26, 2006 6:08 am

Postby Alexej Kubarev » Sun Feb 26, 2006 1:27 pm

hmmz... are you sure you have the mysqli extention ENABLED in your php.ini ?
well, this is veeery weird, seems to me that the was the problem with how the passwords should be saved or something.

how about removing your password at all? can you login then?
User avatar
Alexej Kubarev
Site Admin
Site Admin
 
Posts: 2223
Joined: Fri Mar 05, 2004 7:15 am
Location: Täby, Stockholms län

Postby Sharky01276 » Sun Feb 26, 2006 3:00 pm

again not able to login with blank password..

lol it is very very wierd...

um not sure what you mean with php.ini?
Sharky01276
New php-forum User
New php-forum User
 
Posts: 4
Joined: Sun Feb 26, 2006 6:08 am


Return to phpMyAdmin

Who is online

Users browsing this forum: No registered users and 1 guest

Sponsored by Sitebuilder Web hosting and Traduzioni Italiano Rumeno and antispam for cPanel.

cron