Board index   FAQ   Search  
Register  Login
Board index php forum :: php coding PHP coding => General

Protecting directory causes error...

Ask about general coding issues or problems here.

Moderators: macek, egami, gesf

Protecting directory causes error...

Postby network23 » Wed Jan 29, 2003 9:36 am

I've set up phpMyAdmin on a Windows 2000 box running IIS (not my choice). It appears to run just fine, but as strongly suggested in the docs, I should protect the directory so as to prevent others messing about with the db's.

Whenever we try to protect the directory however, when we get past the security, phpMyAdmin refuses to run, giving us this error:

Fatal error: Failed opening required './libraries/grab_globals.lib.pp' (include_path='.;c:\php4\pear') in D:\path\to\phpmyadmin

It may be helpful to know that when I run phpinfo, phpinfo runs just fine, but this is at the top of the result document...

Warning: Failed opening 'arttest.htm' for inclusion (include_path='.;c:\php4\pear') in D:\path\to\phpinfo.php on line 8

I'd also love to know what causes the above error and how to correct it.

Thanks!
network23
New php-forum User
New php-forum User
 
Posts: 2
Joined: Wed Jan 29, 2003 9:27 am

Postby Joan Garnet » Wed Jan 29, 2003 4:44 pm

It depends on which pemissions you gave.
You should allow at least read.
What did you changed exactly?
User avatar
Joan Garnet
Moderator
Moderator
 
Posts: 387
Joined: Sat Aug 03, 2002 2:56 am
Location: Mars


Return to PHP coding => General

Who is online

Users browsing this forum: Google [Bot], Google Feedfetcher and 6 guests

Sponsored by Sitebuilder Web hosting and Traduzioni Italiano Rumeno and antispam for cPanel.

cron