Board index   FAQ   Search  
Register  Login
Board index PHP PHP Installation

Stucked at bottleneck (installation)

Forum for you who has PHP installation issues

Moderators: macek, egami, gesf

Stucked at bottleneck (installation)

Postby Mohammad_Ali » Sun Dec 22, 2002 11:02 am

I downloaded the phpdev4 and installed it on my Windows 98. Before installation (and even after installing) PWS was running.
I installed PHP, Apache, and MySQl.

But still I am getting this message
----------------------------------------------
Security Alert! The PHP CGI cannot be accessed directly.

This PHP CGI binary was compiled with force-cgi-redirect enabled. This means that a page will only be served up if the REDIRECT_STATUS CGI variable is set, e.g. via an Apache Action directive.

-------------------------------------------------
Can anyone please help me. Am I missing something to configure??

Mohammad Ali
(first step in PHP world)
Mohammad_Ali
New php-forum User
New php-forum User
 
Posts: 3
Joined: Sun Dec 22, 2002 10:39 am

Postby Joan Garnet » Sun Dec 22, 2002 1:28 pm

Edit your PHP.INI file in the Windows directory:
The semicolon in front of cgi.force_redirect=0 must be missing! This 'uncomments' the line and enables the feature, which in this case sets cgi.force_redirect to false.

Something like this -->

Code: Select all
; cgi.force_redirect = 1
cgi.force_redirect=0


Byes
;)
User avatar
Joan Garnet
Moderator
Moderator
 
Posts: 387
Joined: Sat Aug 03, 2002 2:56 am
Location: Mars

Re: Stucked at bottleneck (installation)

Postby WiZARD » Mon Dec 23, 2002 12:46 am

Or try set PHP like Module not like CGI
User avatar
WiZARD
Moderator
Moderator
 
Posts: 1257
Joined: Thu Jun 20, 2002 10:14 pm
Location: Ukraine, Crimea, Simferopol

Changed the Redirect But still the same... Huh!!

Postby Mohammad_Ali » Mon Dec 23, 2002 4:10 am

I did changed the line in php.ini residing in windows folder
to
; cgi.force_redirect = 1

but still the same, even now I am getting the same error message about CGI
OR can you help me to set my PHP like module not like CGI
thanks anyway,
Mohammad Ali
(Stucked badly)
Mohammad_Ali
New php-forum User
New php-forum User
 
Posts: 3
Joined: Sun Dec 22, 2002 10:39 am

Postby Joan Garnet » Mon Dec 23, 2002 4:39 am

; cgi.force_redirect is necessary to provide security running PHP as a CGI under
; most web servers. Left undefined, PHP turns this on by default.

So you've got it by default now, nothing's changed yet.

What you should do is left it like this -->
Code: Select all
; cgi.force_redirect = 1
cgi.force_redirect = 0

As you see I add a line setting it to false.
P.D. Try to stop Apache service while changing things.

Try it.
I hope it'll work fine, otherwise you'll have to download the CGI module for Apache at http://www.php.net/downloads.php
User avatar
Joan Garnet
Moderator
Moderator
 
Posts: 387
Joined: Sat Aug 03, 2002 2:56 am
Location: Mars

Thanks Guys

Postby Mohammad_Ali » Tue Dec 24, 2002 10:11 am

WOW
I have finally seen the working PHP page.
Thanks guys (Joan Garnet & WiZARD)
thanks all
Mohammad_Ali
New php-forum User
New php-forum User
 
Posts: 3
Joined: Sun Dec 22, 2002 10:39 am

Re: Thanks Guys

Postby WiZARD » Wed Dec 25, 2002 12:08 am

I'm propose install PHP Like module (in Winows or UNIX)
cause it's faster and not have more problem....
User avatar
WiZARD
Moderator
Moderator
 
Posts: 1257
Joined: Thu Jun 20, 2002 10:14 pm
Location: Ukraine, Crimea, Simferopol


Return to PHP Installation

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

Sponsored by Sitebuilder Web hosting and Traduzioni Italiano Rumeno and antispam for cPanel.

cron