PHP form OK in Firefox, messed up in IE6

Questions and tutorials related to Cascading Style Sheets *all versions*

Moderators: macek, egami, gesf

shawbapmp
New php-forum User
New php-forum User
Posts: 23
Joined: Mon Sep 06, 2004 6:13 am
Location: Toronto

PHP form OK in Firefox, messed up in IE6

Postby shawbapmp » Mon Aug 15, 2005 6:39 pm

Hi PHP'ers,

I have a survey form that displays and works fine with the Firefox browser, but displays right-shifted (by about 500 px's) in IE. I've seen a few discussion threads on this, but it's the other way around, with IE OK and Firefox displaying wrong.

Here's a code sample of the affected objects that appear to the right in IE:

Code: Select all

<form method="POST" action="'.$PHP_SELF.'">
<p><span style="position: absolute; left: 217; top: 431">
<img width="490" height="193" src="survey_files/image001.gif"></span></p>
<input TYPE="hidden" NAME="VTI-GROUP" VALUE="1">
<div style="position: absolute; top: 473; left: 290; width: 40; height: 40">
    <span style="position: absolute; left: 0; top: 1; z-index:1">
    <input type="radio" value="Yes" name="Q1YesNo"></span>
     <span style="position: absolute; left: 0; top: 17; z-index:1">
    <input type="radio" value="No" name="Q1YesNo"></span>
    </div>


In the above, image001.gif is a text box image with a question and the hidden group box contains the Yes and No options buttons. Instead of displaying at 217 px's from the left, the image shows up at about the 500 px position. Ditto for the radio buttons.

Any suggestions on what code mods I should make to clear up browser inconsistencies? I'm not a pro at HTML or PHP coding, so don't crucify me for not knowing W3 standards or whatever you call it.

User avatar
gesf
Moderator
Moderator
Posts: 1717
Joined: Sun Dec 29, 2002 5:03 am
Location: Portugal / Sweden
Contact:

Postby gesf » Mon Aug 15, 2005 9:28 pm

First: Please use code tag next time.

Second: There's no PHP form. :)
That's HTML. Also this is likely an Html and/or Css issue than PHP so... topic moved to CSS forum.

User avatar
gesf
Moderator
Moderator
Posts: 1717
Joined: Sun Dec 29, 2002 5:03 am
Location: Portugal / Sweden
Contact:

Postby gesf » Mon Aug 15, 2005 9:44 pm

Try putting the px in your dimension values. Anyways... i think it will just invert the situation.

shawbapmp
New php-forum User
New php-forum User
Posts: 23
Joined: Mon Sep 06, 2004 6:13 am
Location: Toronto

Postby shawbapmp » Tue Aug 16, 2005 4:49 am

Hi GESF,

Yes, I guess it is a CSS issue. To rrespond to your comments, the code sample is part of a PHP form. The first part which I didn't show is just an ECHO statement to display the page with survey questions and form inputs, and the last part that I didn't show was the PHP code to write to a text file. And that wonderfull little piece of code was provided to me last week by you! Thanks again.

I tried putting in the PX values but it made no difference. Oddly, the first part of HTML code with the banner, intro images, and left margin, which come before the FORM POST statement, all display correctly. It's only the stuff after, which I've shown in my first message.

I'd appreciate any help on this annoying issue.

And I don't want to sound too ignorant, but what are code tags?

shawbapmp
New php-forum User
New php-forum User
Posts: 23
Joined: Mon Sep 06, 2004 6:13 am
Location: Toronto

Postby shawbapmp » Tue Aug 16, 2005 8:45 am

OK, so I'm posting a reply to my own message. But I got things fixed.

I'm not sure what I did, but things started happening after I inserted a line for <style type="text/css"></style>.

No need to reply any further to this thread.
Thanks folks.


Return to “CSS”

Who is online

Users browsing this forum: No registered users and 0 guests