Board index   FAQ   Search  
Register  Login
Board index php forum :: Database MySQL Installation

Access Denied

Installation and configuration iussues

Moderators: macek, egami, gesf

Postby bezmond » Sat Sep 25, 2004 9:22 pm

Try using localhost instead of 127.0.0.1, also if you are hosting elsewherem check that your host doesn't require a specific address writing there (mine does).

Andrew
User avatar
bezmond
Moderator
Moderator
 
Posts: 312
Joined: Sat Apr 05, 2003 4:33 am
Location: Mansfield, UK

Mysql Installation

Postby bigal » Sun Oct 10, 2004 6:33 am

I have the same issue exactly.

Installing on a system with windows xp / norton internet security. I have tried several versions of mysql. Still cant connect after successful installation. :shock:

I tried the grant privlege * thingie, and even created a new user through phpMyAdmin.

When I tried version 4.1.5, after successful upload and using phpMyAdmin, (config, username, user password) when I got the popup window for the user name and password, nothing I entered was accepted. You could try it 3 times then got a screen change - access denied. :shock:

In one case, the only version I could connect on (phpMyAdmin) was 4.0.0a. When I wrote the db via php form, it would not show the result although it actually wrote the data to the db. :help:

I did removed norton and did a restore back to july. No luck :shock:

Is this an OS issue? or ?? Any help would be greatly appreciated.

Kind regards,
Big Al - Rowlett, Texas
bigal
New php-forum User
New php-forum User
 
Posts: 6
Joined: Sun Oct 10, 2004 6:13 am
Location: Rowlett, Texas

Postby Alexej Kubarev » Sun Oct 10, 2004 9:53 am

this is really weird because ites surely not an OS issue...
try installing phpMyAdmin 2.6.0 pl1 even thou all other versions are working fine..
dont forget to set some variables in the config.inc.php file.

The main problem is that you are using a root as a username for the entire DB engine..
change the username and a password in MySQLAdmin that is distributed with the MySQL and then set those username and a password in the phpMyAdmin's config.inc.php file..

This will work... or atleast should work... you might have already done that before,,, but try again.. with a aclean install... i would set an Auth method to HTTP if i were you..

good luck guys :)
mail me if something is not working
User avatar
Alexej Kubarev
Site Admin
Site Admin
 
Posts: 2223
Joined: Fri Mar 05, 2004 7:15 am
Location: Täby, Stockholms län

Postby Alexej Kubarev » Sun Oct 10, 2004 11:13 am

Okej... i found out that ive made one mistake**atleast** while explaining..
http and cookie types of access do not need a password in the config.inc.php... only the congig type does..
Also i forgot to tell thats its very important to set blowfish secret.

So im not really sure what kind of error you are getting... i need to see that with my own eyes or you sjould paste&copy them here..

But it sounds to me that you might've forgoten to save settings/reload mysql after changing the pass/username.

Try doing that..
User avatar
Alexej Kubarev
Site Admin
Site Admin
 
Posts: 2223
Joined: Fri Mar 05, 2004 7:15 am
Location: Täby, Stockholms län

MySql Installation - Access denied

Postby bigal » Sun Oct 10, 2004 7:36 pm

Well......... I removed the version I was trying to install. Went to 4.1.5.
btw: I am using XP Professional.

When I ran the setup utility, it said that it could not create windows service for mysql; error:0

I got it to install by setting the service up in XP's view network connecitons utility. Here is where I went and what I did.

Start>networkplaces>view network connections

right click on local area connection

click on properties

Click Advanced tap

Make sure that the Protect my computer and network......
box is checked. Then click on the setting button at the
bottom of this window.

Check the Web Server (HTTP) box.

Click OK

Rebooted the computer and sucessfully installed 4.1.5.

Although I STILLhave the access denied error :shock:

Again, THANK YOU, Alexei, for your efforts. They were more than appreciated.

Kind regards,
G. Allen Cummings
Rowlett, Texas
bigal
New php-forum User
New php-forum User
 
Posts: 6
Joined: Sun Oct 10, 2004 6:13 am
Location: Rowlett, Texas

Postby ruturajv » Sun Oct 10, 2004 9:59 pm

have you tried this using the command line
User avatar
ruturajv
php-forum Super User
php-forum Super User
 
Posts: 1280
Joined: Sat Mar 22, 2003 9:42 am
Location: Mumbai, India

Postby Alexej Kubarev » Mon Oct 11, 2004 2:44 am

I think they wrote about using a command line... and it worked for them...
i think its just their configuration files that have some misstakes... this i was able to understand from one of the emails that i recieved.

If some of you would post their config files --- atleast a part of it..
then i might be able to help a bit more...
User avatar
Alexej Kubarev
Site Admin
Site Admin
 
Posts: 2223
Joined: Fri Mar 05, 2004 7:15 am
Location: Täby, Stockholms län

Postby bigal » Mon Oct 11, 2004 4:26 am

Hi guys,

First of all, I solved the "no access" error as mentioned in my last post. It was related to the config of my OS.

Now I get "incorrect user/password" error.

command line works just fine. Did the grant all and everything else in the manual.

It should be noted that when I set the config.inc.php file for phpMyAdmin [latest version] type = 'config' and user = 'root and password = ''[nothing], I can access MySql.

It's when I put anything else in the username and password [as shown by the admin utility that comes with MySql] that I get the "password/user" incorrect error.

FYI - I didn't have any issues when using Win 2000 prof edition. This XP prof edition has not been what I thought. When originally installed, the installer suggested to use the upgrade option, which I did. Lots of issues. I wound up wiping the drive and doing a clean install with XP. I don't know if this XP is cracked up to be what Microsoft said it was......... anyway...... :sad:

:-D Again, thanks to all for the posts. I appreciate your input and kindness.

Kind regards,
G. Allen Cummings
Rowlett, Texas
bigal
New php-forum User
New php-forum User
 
Posts: 6
Joined: Sun Oct 10, 2004 6:13 am
Location: Rowlett, Texas

success!

Postby bigal » Mon Oct 11, 2004 4:43 am

OK.......... I set type = 'http' user to 'username' and password to ' '

When the popup window came up, I only put the username.....nothing in the password and got access.

What a deal....... :grin:

G. Allen Cummings
Rowlett, Texas
bigal
New php-forum User
New php-forum User
 
Posts: 6
Joined: Sun Oct 10, 2004 6:13 am
Location: Rowlett, Texas

Postby Alexej Kubarev » Mon Oct 11, 2004 9:32 am

Well the deal is that in the config file you should set the MySQL access information... the one that is set in my.ini file of the mysql database administration..
Http access type needs only username to be saved in the phpmyadmin config.inc.php

After you've loged in you should create a new user and give it full access with a password protection... this way you will have to use that user instead..

;-)
User avatar
Alexej Kubarev
Site Admin
Site Admin
 
Posts: 2223
Joined: Fri Mar 05, 2004 7:15 am
Location: Täby, Stockholms län

Postby bigal » Mon Oct 11, 2004 2:26 pm

THANK YOU, Alexei. Your suggestion will be utilized.

Again, I appreciate your effort in helping me with this issue.

Kind regards,

G. Allen Cummings
Rowlett, Texas

Websites:
[url]http://www.isaaccummingsfamily.org][/url]
http://www.estructuredweb.com/tartanday/
http://www.grandlodgeoftexas.org
http://www.easttrinity.com
bigal
New php-forum User
New php-forum User
 
Posts: 6
Joined: Sun Oct 10, 2004 6:13 am
Location: Rowlett, Texas


Return to MySQL Installation

Who is online

Users browsing this forum: No registered users and 2 guests

Sponsored by Sitebuilder Web hosting and Traduzioni Italiano Rumeno and antispam for cPanel.