how can I increase the max. acceptable size for a SQL file?

How to use phpmyadmin.... phpmyadmin related arguments. Even phpMyAdmin issues

Moderators: macek, egami, gesf

aupadmin

how can I increase the max. acceptable size for a SQL file?

Postby aupadmin » Sat May 29, 2004 3:30 am

Hello all!

I have a phpbb forum running on an Internet server and I also want to install it locally on my computer, so that I can test an upgrade and make sure everything goes smoothly, before going on with the real thing.

Therefore, I needed to have an apache server installed as a localhost on my computer, which I did. The information about it:

Apache Web Server Version 1.3.29
PHP Script Language Version 4.3.6
MySQL Database Version 4.0.18
Zend Optimizer Version 2.5.1
phpMyAdmin Database Manager Version 2.5.6


Now, I went to the online phpmyadmin and made a full export of the database which I could then upload in my local phpmyadmin. It's quite big, about 162,000 KB. So I know I might need to do an export for each table.

But still, I'm sure I'm going to have a problem, because my local phpmyadmin seems to have a limit established for the size of the SQL files that can be imported, as little as 2,048 KB!! :-o :-o

So the question is: how can I modify this limit on my local phpmyadmin so that I can upload bigger files?

Thanks a lot for your help :help:

aupadmin
New php-forum User
New php-forum User
Posts: 3
Joined: Sat May 29, 2004 3:36 am

Postby aupadmin » Sat May 29, 2004 3:40 am

Er... This is not a bump, :oops: , it's just that I decided to register so that I can receive notifications, sorry! :)

User avatar
ruturajv
php-forum Super User
php-forum Super User
Posts: 1280
Joined: Sat Mar 22, 2003 9:42 am
Location: Mumbai, India
Contact:

Postby ruturajv » Sun May 30, 2004 9:02 pm

you can do the follopwing...


gZip the sql file and then try to use it..

Code: Select all

tar -zcvf sqlfile.tar.gz sqlfile.sql

aupadmin
New php-forum User
New php-forum User
Posts: 3
Joined: Sat May 29, 2004 3:36 am

Postby aupadmin » Sun May 30, 2004 11:15 pm

Thanks for your reply but... I exported a table gzipped from the online database and it's still too big to upload it into my local database. 2,048 KB is too small a size limit, really.

:(

User avatar
Pulse
New php-forum User
New php-forum User
Posts: 53
Joined: Sat Jan 03, 2004 8:32 am
Location: South Africa, Gauteng, JHB
Contact:

Postby Pulse » Tue Jun 01, 2004 4:02 am

I'm also stuck with the same problem

aupadmin
New php-forum User
New php-forum User
Posts: 3
Joined: Sat May 29, 2004 3:36 am

Postby aupadmin » Tue Jun 01, 2004 4:04 am

I got the following reply in SourceForge.net:

Edit the following lines in your php.ini file:

; Maximum size of POST data that PHP will accept.
post_max_size = 55M

; Maximum allowed size for uploaded files.
upload_max_filesize = 10M

These aren't the default settings. So change it to how you see fit.


This is the solution to the size limit problem. However, now I get "SQL query doesn't exist". I'm still working on it trying to find a solution. :shock:


Return to “phpMyAdmin”

Who is online

Users browsing this forum: No registered users and 0 guests

cron