db paging: 404 not found

Links for php scripts

Moderators: macek, egami, gesf

mpgalvin
New php-forum User
New php-forum User
Posts: 12
Joined: Sun Jan 12, 2003 2:53 am

db paging: 404 not found

Postby mpgalvin » Tue Sep 30, 2003 10:12 am

I've got a page that has a dropdown on it so that the user can select how many records to show on each page. I'm writing that value to a cookie, etc.

The values are 5, 10, 15, 20, and 25, but when I select '25' from the dropdown, I'm redirected to a 404. When I go back in, the 25 has been saved, and I can see the first 25 records. Also, sometimes '20' works, sometimes it doesn't.

I've tried ob_start, etc to try and break down what's going on, but I can't. Any help?

Admin: please move to php coding -> general forum

User avatar
pootergeist
New php-forum User
New php-forum User
Posts: 191
Joined: Wed Jan 29, 2003 7:11 am
Location: UK
Contact:

Postby pootergeist » Tue Sep 30, 2003 11:17 am

I'd guess that you have a snag in your code somewhere.

If you'd be kind enough to show us the code we might have a much better chance of deducing exactly what is fubar.

mpgalvin
New php-forum User
New php-forum User
Posts: 12
Joined: Sun Jan 12, 2003 2:53 am

Postby mpgalvin » Tue Sep 30, 2003 2:37 pm

All well and good, but since I'm still developing, there is no templating or anything going on, so the offending file is over 1500 lines long. And I have no idea whereabouts the 'problem' is. I'm pretty sure you don't want 1500 lines of code posted here :)

I uploaded the file to my domain, and it works perfectly, so it would appear to be just a local problem. No biggie - I'll just never cause the error, but it must be a local Apache setup thing. Right?

User avatar
WiZARD
Moderator
Moderator
Posts: 1257
Joined: Thu Jun 20, 2002 10:14 pm
Location: Ukraine, Crimea, Simferopol
Contact:

Postby WiZARD » Wed Oct 01, 2003 2:52 am

mpgalvin wrote:All well and good, but since I'm still developing, there is no templating or anything going on, so the offending file is over 1500 lines long. And I have no idea whereabouts the 'problem' is. I'm pretty sure you don't want 1500 lines of code posted here :)

I uploaded the file to my domain, and it works perfectly, so it would appear to be just a local problem. No biggie - I'll just never cause the error, but it must be a local Apache setup thing. Right?

try find in your code place where you process form, couse submission it's just a form processing. maby you have a link at the SELF directive not correct or not existing file. Than you get error about not existing file and have error 404.

mpgalvin
New php-forum User
New php-forum User
Posts: 12
Joined: Sun Jan 12, 2003 2:53 am

Postby mpgalvin » Wed Oct 01, 2003 4:27 am

Y'see, the thing is it works fine under certain circumstances (yeah, the worst kind of bug to find). I suspect it's something to do with caching, and that online this has been done properly, but on my local server, it's still the basic level. Or something.


Return to “PHP Scripts”

Who is online

Users browsing this forum: No registered users and 2 guests

cron