What is the replacement of dl() in php-5.3 onwards?

Links for php scripts

Moderators: macek, egami, gesf

Antrikssh
New php-forum User
New php-forum User
Posts: 22
Joined: Wed May 02, 2012 5:27 am

What is the replacement of dl() in php-5.3 onwards?

Postby Antrikssh » Thu Jul 19, 2012 8:14 am

Hello Everyone,

I worked with php last one month. When I started, I have installed php-5.3 with apache(http) server. I configured it and start working but, when I used dl() in my script it was not supported by php-5.3. When I was read about that, I found this statement "5.3.0, dl() is now disabled in some SAPIs due to stability issues. The only SAPIs that allow dl() are CLI and Embed.". If it is deprecated from php-5.3 onwards then what is the replacement of that. I also found one link just after the statement that I mentioned is "Use the Extension Loading Directives instead." but, I unable to understand what should I do with that directives.

Please tell me the setting if there is any for dl() in php-5.3 onwards.


Thanks & Regards,

Antrikssh....... :D

Jeroen
New php-forum User
New php-forum User
Posts: 40
Joined: Fri Aug 10, 2012 4:37 pm
Contact:

Re: What is the replacement of dl() in php-5.3 onwards?

Postby Jeroen » Mon Aug 13, 2012 4:40 pm

You can enable dl in your php.ini file: enable_dl = on
But i advice to just enable the extension, instead of loading it dynamically.


Return to “PHP Scripts”

Who is online

Users browsing this forum: No registered users and 1 guest