HTTPS problem / Commentics

Discussions about server security -- questions and answeres

Moderators: macek, egami, gesf

Post Reply
ronwooduk
New php-forum User
New php-forum User
Posts: 17
Joined: Tue Apr 19, 2011 4:23 am

HTTPS problem / Commentics

Post by ronwooduk » Mon Mar 07, 2016 6:43 am

Hi All,
I have been using commentics ( customer reviews and ratings ) on my site for ages, no problems. I have just obtained an SSL certificate and am now trying to get the green padlock. I have removed most scripts etc that are insecure but I am having trouble with Commentics. When I test my page I get this:

30index.php:774 Mixed Content: The page at 'https://www.jollygoodfun.co.uk/index.php#cmtx_form' was loaded over HTTPS, but requested an insecure image 'http://jollygoodfun.co.uk/comments/imag ... r_full.png'. This content should also be served over HTTPS.

It shows thirty errors. They are the thirty stars for my customer ratings / reviews. I don't want to disable them.

As the images are already stored on my server why am I getting this error message?

I have searched through the php code in commentics looking for all code relating to images and added s to any http references but still I get this.

Can anyone help or tell me what I need to do to get round this. I only have a basic knowledge of php ( self taught ) so need a bit of expert guidance here.

Thanks a lot, Ron

ronwooduk
New php-forum User
New php-forum User
Posts: 17
Joined: Tue Apr 19, 2011 4:23 am

Re: HTTPS problem / Commentics

Post by ronwooduk » Mon Mar 07, 2016 8:00 am

I have found the solution. Problem solved.
Thank you for looking.
Ron

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest