Board index   FAQ   Search  
Register  Login
Board index System Administration Server installation and configuration

.htaccess help !!!!

Discuss server installationa nd configuration issues here

Moderators: macek, egami, gesf

.htaccess help !!!!

Postby d.shankar » Sun Apr 02, 2006 6:59 pm

hi all !

i need to create custom error documents for my site...

if any page is not available it must redirect to my customized error page instead of the same old " 404 page not found !"

to do this we need .htaccess file i have all things correctly in the file but it is not working..

this is my .htaccess file

ErrorDocument 404 http://www.2xceed.net/Error.php?404 Page Not Found !
User avatar
d.shankar
New php-forum User
New php-forum User
 
Posts: 71
Joined: Fri Jul 29, 2005 2:17 am

Postby d.shankar » Sun Apr 02, 2006 7:00 pm

please some one help me frame out this problem ...

Advanced thanks
User avatar
d.shankar
New php-forum User
New php-forum User
 
Posts: 71
Joined: Fri Jul 29, 2005 2:17 am

Postby Coditor » Sun Apr 02, 2006 11:59 pm

Does it redirect to anything at all?


Try this:

ErrorDocument 404 /Error.php?404%20Page%20Not%20Found%20!


Coditor
Coditor
New php-forum User
New php-forum User
 
Posts: 243
Joined: Wed Feb 01, 2006 9:18 am
Location: Netherlands

Postby Shiv » Mon Apr 03, 2006 12:02 am

Look at it. It might help u

http://lists.debian.org/debian-apache/2 ... 00173.html


or truncate your url to /Error.php?404
User avatar
Shiv
php-forum Active User
php-forum Active User
 
Posts: 262
Joined: Wed Feb 02, 2005 8:06 pm
Location: Ahmedabad (Gujarat), INDIA

Postby sanketce » Mon Apr 03, 2006 5:33 am

Here is your solution.....

http://www.debianhelp.co.uk/customerrors.htm

Thanks

Sanket
sanketce
New php-forum User
New php-forum User
 
Posts: 90
Joined: Fri Dec 02, 2005 3:23 am

Postby d.shankar » Mon Apr 03, 2006 8:55 am

Guys it didnt help out.. :( But thanks a lot of effort by u all

i asked the my domain administrator whether custome error messages can be set or not ?

he said they can be set and he told me to give the links for error messages like 404,500 etc..

so it is clear that .htaccess will work in my site .. but how to do it by myself ??

Each and every time i may not able to contact him... please help guys !!!
User avatar
d.shankar
New php-forum User
New php-forum User
 
Posts: 71
Joined: Fri Jul 29, 2005 2:17 am

Postby sanketce » Mon Apr 03, 2006 8:54 pm

So your problem is seeming that you want to open a custom error page on a particular page request fails (#404) like if page is not found?
sanketce
New php-forum User
New php-forum User
 
Posts: 90
Joined: Fri Dec 02, 2005 3:23 am

Postby d.shankar » Tue Apr 04, 2006 3:32 am

yeah that custom error thing is not working in my site.... :(


i dont know what to do ??
User avatar
d.shankar
New php-forum User
New php-forum User
 
Posts: 71
Joined: Fri Jul 29, 2005 2:17 am

Postby sanketce » Tue Apr 04, 2006 5:24 am

I think your domain administrator will help you out in this case. 8)
sanketce
New php-forum User
New php-forum User
 
Posts: 90
Joined: Fri Dec 02, 2005 3:23 am

Postby d.shankar » Tue Apr 04, 2006 6:34 am

hey sanket it is very difficult to contact him each and every time..

there must some way to fix this .htaccess thing...

i wonder why it is not working ???
User avatar
d.shankar
New php-forum User
New php-forum User
 
Posts: 71
Joined: Fri Jul 29, 2005 2:17 am

Postby Shiv » Tue Apr 04, 2006 6:26 pm

Let me know that in htaccess other directives or instructions are working or not.
User avatar
Shiv
php-forum Active User
php-forum Active User
 
Posts: 262
Joined: Wed Feb 02, 2005 8:06 pm
Location: Ahmedabad (Gujarat), INDIA

Postby sanketce » Tue Apr 04, 2006 8:53 pm

Can you post your some portion of your .htaccess fle?
sanketce
New php-forum User
New php-forum User
 
Posts: 90
Joined: Fri Dec 02, 2005 3:23 am

Postby d.shankar » Wed Apr 05, 2006 7:06 am

sanketce wrote:Can you post your some portion of your .htaccess fle?


ErrorDocument 404 /Error.php?404%20Page%20Not%20Found%20!
User avatar
d.shankar
New php-forum User
New php-forum User
 
Posts: 71
Joined: Fri Jul 29, 2005 2:17 am

Postby sanketce » Wed Apr 05, 2006 8:47 pm

This is correct written I couldn't find anything wrong in this.
sanketce
New php-forum User
New php-forum User
 
Posts: 90
Joined: Fri Dec 02, 2005 3:23 am

Postby d.shankar » Thu Apr 06, 2006 12:29 am

hmm..

then i am unable to trace the problem !!!

u have any clue sanket ??
User avatar
d.shankar
New php-forum User
New php-forum User
 
Posts: 71
Joined: Fri Jul 29, 2005 2:17 am

Postby sanketce » Thu Apr 06, 2006 2:59 am

You can do one thing, check your all APACHE settings now this is only one way is remaining.
sanketce
New php-forum User
New php-forum User
 
Posts: 90
Joined: Fri Dec 02, 2005 3:23 am


Return to Server installation and configuration

Who is online

Users browsing this forum: No registered users and 2 guests

Sponsored by Sitebuilder Web hosting and Traduzioni Italiano Rumeno and antispam for cPanel.