Mongo PHP driver - differents API :(

Discuss server installationa nd configuration issues here

Moderators: macek, egami, gesf

alphastorm
New php-forum User
New php-forum User
Posts: 1
Joined: Tue Feb 04, 2014 7:45 am

Mongo PHP driver - differents API :(

Postby alphastorm » Tue Feb 04, 2014 8:02 am

Hello everyone,

I spent 2 days trying to install mongo php driver on a Mac 10.8 with MAMP (2.2), but it's almost impossible...
I have the 5.4.19 php version selected on MAMP.

I have installed the mongo driver doing:

Code: Select all

sudo pecl install mongo


I have no errors, but once I restart MAMP I got this error on the loading process:

Code: Select all

PHP Warning:  PHP Startup: mongo: Unable to initialize module
        Module compiled with module API=20090626
        PHP    compiled with module API=20121212
        These options need to match
        in Unknown on line 0


The output of phpize is:

Code: Select all

 Configuring for:
        PHP Api Version:         20090626
        Zend Module Api No:      20090626
        Zend Extension Api No:   220090626


The output of php -v is:

Code: Select all

PHP 5.5.3 (cli) (built: Sep 18 2013 14:31:13) ...


So the version doesn't match with MAMP.
I have tried to select the same version on MAMP, but I got the same problem...

Any hints? Please!!

Return to “Server installation and configuration”

Who is online

Users browsing this forum: No registered users and 1 guest

cron