Board index   FAQ   Search  
Register  Login
Board index System Administration Server installation and configuration

Problem with mod_rewrite (?) on Apache

Discuss server installationa nd configuration issues here

Moderators: macek, egami, gesf

Problem with mod_rewrite (?) on Apache

Postby jakubfox » Mon Feb 20, 2012 4:59 am

Hi, I have a problem with Apache/PHP configuration:

PHP scripts doesn't work when there is a slash after script name, ie.:

localhost/test.php/
localhost/test.php/foo
Gives:
Code: Select all
Not Found
The requested URL /test.php/costam was not found on this server.


- .htaccess seems to work, I've tested that using this simple rewrite rule:
Code: Select all
RewriteEngine on
RewriteRule ^alice.html$ bob.html


When there is no slash directly after the script name, everything seems to work fine:

localhost/test.php
localhost/test.php?boo=foo
localhost/test.php?boo=foo/boofoo
localhost/test.php?boo=foo/boofoo/
localhost/test.php?/boo/

/etc/apache2/apache2.conf:
Code: Select all
LockFile ${APACHE_LOCK_DIR}/accept.lock
PidFile ${APACHE_PID_FILE}
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 5
<IfModule mpm_prefork_module>
    StartServers          5
    MinSpareServers       5
    MaxSpareServers      10
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>
<IfModule mpm_worker_module>
    StartServers          2
    MinSpareThreads      25
    MaxSpareThreads      75
    ThreadLimit          64
    ThreadsPerChild      25
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>
<IfModule mpm_event_module>
    StartServers          2
    MinSpareThreads      25
    MaxSpareThreads      75
    ThreadLimit          64
    ThreadsPerChild      25
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}
AccessFileName .htaccess
<Files ~ "^\.ht">
    Order allow,deny
    Deny from all
    Satisfy all
</Files>
DefaultType text/plain
HostnameLookups Off
ErrorLog ${APACHE_LOG_DIR}/error.log
LogLevel warn
Include mods-enabled/*.load
Include mods-enabled/*.conf
Include httpd.conf
Include /etc/phpmyadmin/apache.conf
Include ports.conf
LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent
Include conf.d/
Include sites-enabled/


/etc/apache2/httpd.conf:
Code: Select all
ServerName localhost


/etc/apache2/sites-available/default:
Code: Select all
<VirtualHost *:80>
   ServerAdmin webmaster@localhost

   DocumentRoot /home/john/www
   <Directory />
      Options FollowSymLinks
      AllowOverride All
   </Directory>
   <Directory /home/john/www/>
      Options Indexes FollowSymLinks MultiViews
      AllowOverride All
      Order allow,deny
      allow from all
   </Directory>

   ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
   <Directory "/usr/lib/cgi-bin">
      AllowOverride All
      Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
      Order allow,deny
      Allow from all
   </Directory>

   ErrorLog ${APACHE_LOG_DIR}/error.log

   # Possible values include: debug, info, notice, warn, error, crit,
   # alert, emerg.
   LogLevel warn

   CustomLog ${APACHE_LOG_DIR}/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride All
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>
</VirtualHost>


Phpmyadmin works fine but it has no slashes after script name, only parameters.

I'll apreciate any help with that.
jakubfox
New php-forum User
New php-forum User
 
Posts: 1
Joined: Mon Feb 20, 2012 4:46 am

Return to Server installation and configuration

Who is online

Users browsing this forum: No registered users and 2 guests

Sponsored by Sitebuilder Web hosting and Traduzioni Italiano Rumeno and antispam for cPanel.