PHPmyadmin opens external site on local host

Forum for you who has PHP installation issues

Moderators: macek, egami, gesf

phpchrome
New php-forum User
New php-forum User
Posts: 2
Joined: Sun Oct 30, 2005 11:31 pm

PHPmyadmin opens external site on local host

Postby phpchrome » Mon Oct 31, 2005 12:27 am

When I click "Home" link in phpmyadmin (2.6.3.p11) index.php page, on my local server, it opens external site : http://forums.kustompcs.co.uk/index.php?

I find the link location for "Home" is:
http://localhost8080/pma/main.php?lang=en-utf-8&server=1&collation_connection=utf8_general_ci

The extra strings are added after .php? to another link "QueryWindow" also. Removing extra strings did not help. How did this happen and how it opens the extrnal file. Afterthis, all my other local ".php" files too opened same kustompcs page.

This happend in Firefox1.0.7 browesr. Howewer, when I opened the same in IE, it sais "the page can not be desplayed", but it opened the right page when I removed those extra strings.

Later, when I came back, Firefox too opened the right page, when I opened just http://localhost8080/pma/main.php?. leaving those etra strings. All my other.php files opened currectly.

I have never visited kustompcs.co.uk. How to remove the extra strings added to the links? Please help me to plug the security hole. ( I have broadband connection)

User avatar
ruturajv
php-forum Super User
php-forum Super User
Posts: 1280
Joined: Sat Mar 22, 2003 9:42 am
Location: Mumbai, India
Contact:

Postby ruturajv » Tue Nov 01, 2005 7:20 am

please check the following parameter in config.inc.php

Code: Select all

$cfg['PmaAbsoluteUri'] = 'http://127.0.0.1/phpMyAdmin/';

i think in your case there is a problem with this URL

phpchrome
New php-forum User
New php-forum User
Posts: 2
Joined: Sun Oct 30, 2005 11:31 pm

Postby phpchrome » Wed Nov 02, 2005 8:33 pm

Yes! the colon in localhost:8080 was missing.

Now it is working fine.

Thank you very much!


Return to “PHP Installation”

Who is online

Users browsing this forum: No registered users and 1 guest

cron