PHP 7.1 installation problem

Forum for you who has PHP installation issues

Moderators: egami, macek, gesf

Post Reply
light
New php-forum User
New php-forum User
Posts: 1
Joined: Fri Dec 30, 2016 2:27 am

Fri Dec 30, 2016 3:10 am

I upgrade PHP from version 7.0.9 to 7.1 in Window Server 2016. I have got the follow error.

https://s27.postimg.org/b8knorcir/error2.png

olidev
New php-forum User
New php-forum User
Posts: 4
Joined: Thu Apr 19, 2018 2:48 am

Mon Aug 13, 2018 1:50 am

Are you sure you have upgraded correctly? Ondřej Surý has created this PPA which has the latest versions of PHP in it. Add it to your system, and update to get a list of all the software we can install.

Code: Select all

$ sudo add-apt-repository ppa:ondrej/php
$ sudo apt-get update
install PHP 7.1

Code: Select all

$ service apache2 stop
$ sudo apt-get install php7.1 php7.1-common
Remove PHP 7.0

$ sudo apt-get purge php7.0 php7.0-common

Tell Apache to use PHP7.1 now PHP 7.0 is not being used.

Code: Select all

$ a2enmod php7.1
$ service apache2 restart
In case if you are using managed PHP web hosting platform to upgrade your server. You can find the upgrade option in their panel. Most of the platforms, like cPanel and Plesk makes upgrading easy by providing one click option.

User avatar
benanamen
New php-forum User
New php-forum User
Posts: 53
Joined: Mon Oct 16, 2017 1:06 pm

Mon Aug 13, 2018 3:24 pm

Post the error instead of a broken image link. In any case, there are issues with Php 7.1x. You should run at least 7.2
The XY Problem
The XY problem is asking about your attempted solution (X) rather than your actual problem (Y). This leads to enormous amounts of wasted time and energy, both on the part of people asking for help, and on the part of those providing help.

Post Reply