Board index   FAQ   Search  
Register  Login
Board index PHP PHP Installation

http://localhost.com/test.php

Forum for you who has PHP installation issues

Moderators: macek, egami, gesf

http://localhost.com/test.php

Postby gma_raj » Mon Apr 21, 2003 10:51 pm

Hi All
I relatively new to PHP. Please help. I installed Apache, PHP. Then when I tried to test it by opening a test.php file with just the phpinfo() function in it as follows:

http://localhost/test.php

It doesn't execute the php file which is <? phpinfo(); ?>
instead, sends it for download and when I tried the same with a different filename like test.php3 or test.php4.

http://localhost/test.php3 or
http://localhost/test.php4

it just puts the file content on the browser but doesn't execute the function "phpinfo()"

Please let me know, if I have to change something in the php.ini file.

Thank you
Raj
gma_raj
New php-forum User
New php-forum User
 
Posts: 2
Joined: Mon Apr 21, 2003 10:39 pm

Postby bezmond » Tue Apr 22, 2003 1:44 am

Apache might not be configured correctly, I don't know...

other than that, I suggest trying different addresses like:
http://127.0.0.1/test.php
or http://<external/internal IP address>/test.php
see if either of those are working.

Andrew
User avatar
bezmond
Moderator
Moderator
 
Posts: 312
Joined: Sat Apr 05, 2003 4:33 am
Location: Mansfield, UK

Postby liquedus » Tue Apr 22, 2003 4:45 am

it shouldnt make a difference whether you use 127.0.0.1 or localhost they are both loopbacks. try reinstalling php, http://www.php.net/downloads.php ... and if that doesnt work, let us know.
liquedus
php-forum Active User
php-forum Active User
 
Posts: 266
Joined: Tue Apr 08, 2003 5:18 am
Location: Ottawa, Canada

Postby WiZARD » Thu Apr 24, 2003 3:10 am

funny answers.....
first try just open http://localhost
if you some not erorr than youre server is worked.
If you runing a script, than php not started
try to see info in log files and see info....
User avatar
WiZARD
Moderator
Moderator
 
Posts: 1257
Joined: Thu Jun 20, 2002 10:14 pm
Location: Ukraine, Crimea, Simferopol

Postby mike » Sun May 04, 2003 4:37 am

Which version have you installed? Is it a clear install of apache or just a full pack like Appserv?
User avatar
mike
New php-forum User
New php-forum User
 
Posts: 73
Joined: Sun May 04, 2003 4:26 am
Location: Athens

Postby WiZARD » Thu May 08, 2003 4:01 am

mike wrote:Which version have you installed? Is it a clear install of apache or just a full pack like Appserv?

it's no matter all problem of begginers what whey want just install and work.... about httpd.conf and php.ini forgot...
User avatar
WiZARD
Moderator
Moderator
 
Posts: 1257
Joined: Thu Jun 20, 2002 10:14 pm
Location: Ukraine, Crimea, Simferopol


Return to PHP Installation

Who is online

Users browsing this forum: No registered users and 3 guests

Sponsored by Sitebuilder Web hosting and Traduzioni Italiano Rumeno and antispam for cPanel.