is php.ini being read?

Forum for you who has PHP installation issues

Moderators: macek, egami, gesf

vmayer
New php-forum User
New php-forum User
Posts: 3
Joined: Sat Jun 16, 2012 1:02 pm

is php.ini being read?

Postby vmayer » Sat Jun 16, 2012 1:10 pm

Hi, I'm not convinced my php.ini file is being read. I have xampp installed.

I am trying to add the zend debugger, so I added this to the bottom of C:\xampp\php\php.ini:

[Zend]
zend_extension_ts="C:\Users\earl\Downloads\ZendDebugger-20110410-cygwin_nt-i386\ZendDebugger-20110410-cygwin_nt-i386\5_3_x_nts_comp\ZendDebugger.dll"
zend_debugger.allow_hosts="127.0.0.1"
zend_debugger.expose_remotely=always

I restarted apache in xampp. Then I opened a php page which does a "phpinfo()". I believe I am supposed to see something related to "Zend Modules" but I don't.

So, I tried adding this to php.ini just to see if some sort of error would be flagged:
blah = blah
I don't know - what should happen if you put something like this in your php.ini? I restarted apache, but still my phpinfo() page doesn't seem to have anything in it regarding my "blah=blah" statement.

According to phpinfo(), my "Configuration File (php.ini) Path" is set to C:\Windows. But there is no php.ini file in here. Loaded Configuration File is set to C:\xampp\php\php.ini. I'm not sure if I'm supposed to add php.ini file to the Windows directory or what.

Also, I added C:\xampp\php to my PATH environment variable as well as PHPRC.

Any thoughts?

vmayer
New php-forum User
New php-forum User
Posts: 3
Joined: Sat Jun 16, 2012 1:02 pm

Re: is php.ini being read?

Postby vmayer » Sat Jun 16, 2012 2:33 pm

Well, I made some other changes to the php.ini file, and it looks like they did affect my phpinfo() output, so I guess the file is being read.

Now to figure out why it doesn't like my Zend statements....

vmayer
New php-forum User
New php-forum User
Posts: 3
Joined: Sat Jun 16, 2012 1:02 pm

Re: is php.ini being read?

Postby vmayer » Sat Jun 16, 2012 4:52 pm

After beating my head against the wall all day, I finally decided to install an older version of php: php5.2, and the thing actually works....


Return to “PHP Installation”

Who is online

Users browsing this forum: No registered users and 1 guest

cron