Board index   FAQ   Search  
Register  Login
Board index PHP PHP Installation

Rebuilding legacy system; PHP won't load

Forum for you who has PHP installation issues

Moderators: macek, egami, gesf

Rebuilding legacy system; PHP won't load

Postby safado » Fri Sep 09, 2011 12:54 pm

Short Version: PHP won't load module, giving this error:
Code: Select all
Unable to load dynamic library - Undefined symbol "OPENSSL_add_all_algorithms_noconf" in Unknown on line 0

Long Version:
I have a server that I need to rebuild so that we can have a cold spare available (for legal reason due to the nature of our business). The server that I'm rebuilding is on FreeBSD 4.7, running Apache 1.3, Perl 5.061, MySQL 4.1.19 and PHP 4.4.7. I've tried upgrading some of the software, however I ran into problems with the web service that it's running was using deprecated functions in perl and php and suExec wouldn't work with newer versions of perl or php (forgot which one) and something else wouldn't work if I went with newer versions of FreeBSD, etc, etc. Point being: the way this web app was coded has locked me into using these very specific versions of apache, mysql, php, and perl.

So I've built it using the same setup that we have on the "live" version that our customers are currently using right now. The application will load, basic pages work, cgi scripts work, but anything that tries to make a database connection fails.

Turns out that PHP won't load the module for various reasons. I've sat and battled one by one with the error messages, but I've finally have gotten two different errors that I simply cannot figure out. They are:
Code: Select all
Unable to load dynamic library - Undefined symbol "OPENSSL_add_all_algorithms_noconf" in Unknown on line 0

The above error appears when I type "php" at the command line.

Code: Select all
install_driver(mysql) failed: Can't load '/usr/home/<user>/usr/local/lib/site_perl/auto/DBD/mysql/' for module DBD::mysql: /usr/home/<user>/usr/local/lib/site_perl/auto/DBD/mysql/ Undefined symbol "uncompress" at /usr/local/lib/perl5/5.6.1/mach/ line 206.

This error comes when I use a cgi debug script and I try and go to a page that pulls data from the mysql database. I'm guessing it's related to perl and not php, but I found it odd that they're both complaining about

I've compile PHP (and all the other programs listed above) from source. The configuration options I used were:
Code: Select all
./configure --with-zlib --with-bz2 --with-mysql=/usr/local --with-openssl --with-apxs

I've fought with this for days now and I can't make any progress. I've exhausted Google with no success. Hopefully someone out there has dealt with this issue before and can point me in the right direction.
New php-forum User
New php-forum User
Posts: 1
Joined: Fri Sep 09, 2011 12:18 pm

Return to PHP Installation

Who is online

Users browsing this forum: No registered users and 1 guest

Sponsored by Sitebuilder Web hosting and Traduzioni Italiano Rumeno and antispam for cPanel.