Board index   FAQ   Search  
Register  Login
Board index PHP PHP Installation

problem with "pear install ....."

Forum for you who has PHP installation issues

Moderators: macek, egami, gesf

problem with "pear install ....."

Postby paresh » Sat Feb 05, 2011 11:48 am

i have installed pear on my machine.
I want to install a package called Twitter_Services. According to a tutorial i was following
"pear install Services_Twitter"

is all i was needed to do. However, i am getting this

root@paresh-hp:/etc/php5/apache2# pear install Services_Twitter
Failed to download pear/Services_Twitter within preferred state "stable", latest release is version 0.6.3, stability "beta", use "channel://pear.php.net/Services_Twitter-0.6.3" to install
install failed

-> next tried a different approach

root@paresh-hp:/etc/php5/apache2# pear install channel://pear.php.net/Services_Twitter-0.6.3
Failed to download pear/HTTP_Request2 within preferred state "stable", latest release is version 0.5.2, stability "alpha", use "channel://pear.php.net/HTTP_Request2-0.5.2" to install
Did not download optional dependencies: pear/HTTP_OAuth, use --alldeps to download automatically
pear/Services_Twitter requires package "pear/HTTP_Request2"
pear/Services_Twitter can optionally use package "pear/HTTP_OAuth" (version >= 0.1.7)
No valid packages found
install failed

I tried using --alldeps but even that is not working.

What is going wrong here??
paresh
New php-forum User
New php-forum User
 
Posts: 6
Joined: Sat Feb 05, 2011 11:40 am

Return to PHP Installation

Who is online

Users browsing this forum: No registered users and 1 guest

Sponsored by Sitebuilder Web hosting and Traduzioni Italiano Rumeno and antispam for cPanel.

cron