IIS Error FastCGIModule Not native...

Forum for you who has PHP installation issues

Moderators: egami, macek, gesf

Post Reply
abrogard
New php-forum User
New php-forum User
Posts: 22
Joined: Sat Oct 14, 2006 2:25 am

Fri Apr 13, 2018 8:17 pm

I have win10 with IIS and I'm trying to install PHP following the MS guide on the web.

All is fine until I get to installing the Handler Mapping in IIS where it tells me that the FastCGIModule is not native and asks me to choose at least one enabled native module.

So I can't proceed for there's nothing there that looks likely and I don't want to choose blindly in case it prejudices the whole install and can't be removed.

I'd like some advice/help. I've googled. Found nothing that helps yet. Mainly the most modern advice seems to be to use the MS web installer thing which PHP says is not the best idea because of the extensions it does or doesn't install.

When I try to run phpinfo() via a script on localhost it tells me it can't run it and suggests I need a handler.

So FastCGI is very central to the whole thing it seems.

Can anyone offer any help/advice?

Post Reply