Board index   FAQ   Search  
Register  Login
Board index php forum :: php coding PHP coding => Mail

sending email from apache

the mail() function

Moderators: macek, egami, gesf

sending email from apache

Postby josiah007ng » Sun Jul 18, 2004 7:41 pm

hello guys,

i need some help.

i have installed and have been using php and apache on my system for a while now. i am running apache from my system so that others on the internet can view the site i am hosting on my system with apache when they type my ip address in their browser address bar.

everything is working out fine, but the problem is that the mail function on the site i am hosting on my system is not working at all.the php script executes quite alright but no mail is sent. is there any configuration i have not done yet. pls let me know what i am to do next.

i am running windows 2000.

thank you,
joe...
josiah007ng
New php-forum User
New php-forum User
 
Posts: 2
Joined: Sun Jul 18, 2004 6:55 pm

Postby ruturajv » Sun Jul 18, 2004 10:12 pm

in php.ini check
SMTP = localhost

and you need to start the IIS's SMTP and you need to check relay from 127.0.0.1 to send the mails..

or please check with webmaster of the site .
User avatar
ruturajv
php-forum Super User
php-forum Super User
 
Posts: 1280
Joined: Sat Mar 22, 2003 9:42 am
Location: Mumbai, India

Postby josiah007ng » Mon Jul 19, 2004 3:14 pm

thank you ruturajv, i did all you told me but i do not understand what you meant by checking relay from 127.0.0.1 to send mails. Please explain to me on how i can do this. I await your response.


thank you
josiah007ng
New php-forum User
New php-forum User
 
Posts: 2
Joined: Sun Jul 18, 2004 6:55 pm

Postby ruturajv » Mon Jul 19, 2004 7:37 pm

in your iis services manager...
there is tree for the smtp server for domains...
for that for the local domain's properties, there you find a tab (I don't excatly remember) that the localhost can relay the messages, there you need to add 127.0.0.1 IP, only then you can send the messages
User avatar
ruturajv
php-forum Super User
php-forum Super User
 
Posts: 1280
Joined: Sat Mar 22, 2003 9:42 am
Location: Mumbai, India

Postby cinoz » Wed Oct 27, 2004 9:37 pm

in the properties.. there are two ip address need to be filled in or just one? one is for the default smtp Virtual Server which its IP Address is ' Unassigned Status'.. n one more is in Access- Relay - and there, what i need to add in Access and IP column?...
cinoz
New php-forum User
New php-forum User
 
Posts: 16
Joined: Sun May 23, 2004 10:00 am
Location: Kay Ell

Postby cinoz » Wed Oct 27, 2004 10:55 pm

i had set those Ip Adress.. n the relay things seem vanish.. but, all the sent email now has problem which, the emails now are all stored in my inetpub/mailroot/queue directory.. seems they are stop there n nothing is sent? how to settle this problem?
cinoz
New php-forum User
New php-forum User
 
Posts: 16
Joined: Sun May 23, 2004 10:00 am
Location: Kay Ell


Return to PHP coding => Mail

Who is online

Users browsing this forum: No registered users and 1 guest

Sponsored by Sitebuilder Web hosting and Traduzioni Italiano Rumeno and antispam for cPanel.