Board index   FAQ   Search  
Register  Login
Board index php forum :: php coding PHP coding => Mail

HTML Mail Problems

the mail() function

Moderators: macek, egami, gesf

HTML Mail Problems

Postby bonafidecpo » Thu May 26, 2011 9:47 am

I'm using the mail function to send information from a multi-page session
In some parts of the message the code is coming through and some parts are not showing up at all.

Segment from received mail:

This one is correct:
Business Cards:
Business Cards Requested Business Card Prints Requested 500

These ones obviously have issues:
New Letters:
&nbsp! ;Newslet ters Requested Newsletter Prints Requested 500

Brochures:
! Br ochures Requested Brochure Prints Requested 500

Before I post the code, Any ideas why this may be happening? Most of the email is correct, and its the same copy and pasted code but some parts have these errors.

Thanks,
bonafidecpo
New php-forum User
New php-forum User
 
Posts: 9
Joined: Thu May 26, 2011 9:30 am

Re: HTML Mail Problems

Postby bachans » Fri May 27, 2011 1:53 am

HI,

bonafidecpo wrote:These ones obviously have issues:
New Letters:
&nbsp! ;Newslet ters Requested Newsletter Prints Requested 500


In the code please check that whether It is written like   ! or like &nbsp! ;.

Thanks
Bachan
bachans
New php-forum User
New php-forum User
 
Posts: 67
Joined: Thu May 19, 2011 6:01 am
Location: India

Re: HTML Mail Problems

Postby bonafidecpo » Fri May 27, 2011 10:09 am

Here is the code from that line:

Code: Select all
'<h4>New Letters:</h4>&nbsp;' .        '&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;' . $_SESSION['ne'] . '&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;' . $_SESSION['nep'] . '&nbsp;' . $_SESSION['neq'] . '<br />' .



Thanks,
bonafidecpo
New php-forum User
New php-forum User
 
Posts: 9
Joined: Thu May 26, 2011 9:30 am

Re: HTML Mail Problems

Postby bachans » Fri May 27, 2011 9:58 pm

Hi bonafidecpo,

bonafidecpo wrote: '<h4>New Letters:</h4>&nbsp;' . '&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;' . $_SESSION['ne'] . '&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;' . $_SESSION['nep'] . '&nbsp;' . $_SESSION['neq'] . '<br />' .


This is strange.There is nothing wrong in this code. But one thing I want to mention that there are so many &nbsp; used in the statement. But you can have this type of arrangement by using <table> or <div> tag. Please try other html tags and use lesser &nbsp;. May be it will help you.

Thanks
Bachan
bachans
New php-forum User
New php-forum User
 
Posts: 67
Joined: Thu May 19, 2011 6:01 am
Location: India

Re: HTML Mail Problems

Postby bonafidecpo » Sat May 28, 2011 8:25 am

Thank you,

I'll give it a shot.
bonafidecpo
New php-forum User
New php-forum User
 
Posts: 9
Joined: Thu May 26, 2011 9:30 am

Re: HTML Mail Problems

Postby bonafidecpo » Mon Jun 13, 2011 4:15 pm

Its seems to have worked. I put all the data in tables.

Thanks for the help!
bonafidecpo
New php-forum User
New php-forum User
 
Posts: 9
Joined: Thu May 26, 2011 9:30 am


Return to PHP coding => Mail

Who is online

Users browsing this forum: No registered users and 2 guests

Sponsored by Sitebuilder Web hosting and Traduzioni Italiano Rumeno and antispam for cPanel.