Board index   FAQ   Search  
Register  Login
Board index php forum :: Database phpMyAdmin

phpmyadmin on win2kpro

How to use phpmyadmin.... phpmyadmin related arguments. Even phpMyAdmin issues

Moderators: macek, egami, gesf

phpmyadmin on win2kpro

Postby coolboarderguy » Mon May 16, 2005 7:16 pm

Hi All,

am trying to get phpmyadmin, current ver, to work on win2kpro. I have very limited experience with IIS and win2kpro itself. I am a linux user but need to set this up on my manager's PC. I've installed the phpmyadmin into the inetpub/wwwroot folder but when typing localhost/phpmyadmin, get an access denied message. Sorry, can't post the message, as it's in Japanese(unless of course you can read Japanese-which I can't). Anyone on here running phpmyadmin on windows, particularly on win2kpro, but not essential. I should note, that typing localhost produces the default IIS help page, so IIS is certainly OK.
coolboarderguy
New php-forum User
New php-forum User
 
Posts: 2
Joined: Mon May 16, 2005 7:12 pm
Location: Tokyo

Postby coolboarderguy » Mon May 16, 2005 9:16 pm

Hi All,

I found this tutorial,

http://mpcon.org/apacheguide/

and followed it for the install of apache2/php/phpmyadmin, but, get this error when typing localhost/phpmyadmin in the browser,

cannot load mysql extension;
please check PHP configuration
Documentation

I looked at the output of localhost/index and scrolled down to the list of modules, ad I don't see anmything for mysql.dll

as per changes suggested here from the tutorial

include_path = ".;C:\php\includes\"
session.save_path = "C:\Temp"
session.cookie_path = \
doc_root = "C:\Program Files\Apache Group\Apache2\htdocs"
extension_dir = "C:\php\ext\"
extension=php_mysql.dll
extension=php_mysqli.dll
mysql.default_port = 3306
mysql.default_host = localhost
mysql.default_user = root
mysqli.default_port = 3306
mysqli.default_host = localhost
mysqli.default_user = root

I also got an error about the .dll when restarting apache. Anyone got a solution for this..? Below is my settings for the .dll.

;extension=php_bz2.dll
;extension=php_cpdf.dll
;extension=php_curl.dll
;extension=php_dba.dll
;extension=php_dbase.dll
;extension=php_dbx.dll
;extension=php_exif.dll
;extension=php_fdf.dll
;extension=php_filepro.dll
;extension=php_gd2.dll
;extension=php_gettext.dll
;extension=php_ifx.dll
;extension=php_iisfunc.dll
;extension=php_imap.dll
;extension=php_interbase.dll
;extension=php_java.dll
;extension=php_ldap.dll
;extension=php_mbstring.dll
;extension=php_mcrypt.dll
;extension=php_mhash.dll
;extension=php_mime_magic.dll
;extension=php_ming.dll
;extension=php_mssql.dll
extension=php_msql.dll
extension=php_mysqli.dll
;extension=php_oci8.dll
;extension=php_openssl.dll
;extension=php_oracle.dll
;extension=php_pdf.dll
;extension=php_pgsql.dll
;extension=php_shmop.dll
;extension=php_snmp.dll
;extension=php_sockets.dll
;extension=php_sybase_ct.dll
;extension=php_tidy.dll
;extension=php_w32api.dll
;extension=php_xmlrpc.dll
;extension=php_xsl.dll
;extension=php_yaz.dll
;extension=php_zip.dll

Hope that helps.
coolboarderguy
New php-forum User
New php-forum User
 
Posts: 2
Joined: Mon May 16, 2005 7:12 pm
Location: Tokyo

Postby Alexej Kubarev » Mon May 16, 2005 10:57 pm

hehe..you need to load mysql: it seems that that line is missing from your php.ini.

you way make phpmyadmin to use mysqli instead (config.inc.php).. or add the following line after extension=php_mysqli.dll :

extension=php_mysql.dll
User avatar
Alexej Kubarev
Site Admin
Site Admin
 
Posts: 2223
Joined: Fri Mar 05, 2004 7:15 am
Location: Täby, Stockholms län


Return to phpMyAdmin

Who is online

Users browsing this forum: TurnitinBot [Bot] and 1 guest

Sponsored by Sitebuilder Web hosting and Traduzioni Italiano Rumeno and antispam for cPanel.

cron