Board index   FAQ   Search  
Register  Login
Board index PHP PHP General

PHPEd Strange debugger

General discussions related to php

Moderators: macek, egami, gesf

Re: PHPEd Strange debugger

Postby WiZARD » Tue Nov 19, 2002 11:34 pm

maxbld wrote:Hi to everybody,

While debugging an app with NuSphere PHPEd v3.01 i did notice a very strange buggy behavior: I passed a string containing slashes in a POST variable, an to simulate it in a debug session i entered the following lines in the immediate window:

$parent = "AS UI\\DC\\SGR\\SCR\\SS001"
: string = "AS UI\\DC\\SGR\\SCR\\SS001"

stripslashes($parent)
: string = "AS UIDCSGRSCRSS001"

Funny uh? And the same happens with stripcslashes($parent). Outside the debugger stripslashes($parent) would have returned
"AS UI\DC\SGR\SCR\SS001".

And if i put in the immediate $parent = "AS UI\DC\SGR\SCR\SS001", it echoes:
$parent = "AS UI\DC\SGR\SCR\SS001"
: string = "AS UI\\DC\\SGR\\SCR\\SS001"

So, in fact, i'm unable to put the correct value ("AS UI\DC\SGR\SCR\SS001") in $parent. It seems to be a PHPEd bug. Did everyone of you ever notice it? And if so did you find a workaround?

Thank you a lot.

Max.


Hi1
In a first time i use to PHPEd then NuSphere not have rights for this product.
In first version used debugger by russian man. But how rightnow i don't know....
Actually right now i use PHP Expert Editor by Ankord.
User avatar
WiZARD
Moderator
Moderator
 
Posts: 1257
Joined: Thu Jun 20, 2002 10:14 pm
Location: Ukraine, Crimea, Simferopol

Return to PHP General

Who is online

Users browsing this forum: Google [Bot] and 1 guest

Sponsored by Sitebuilder Web hosting and Traduzioni Italiano Rumeno and antispam for cPanel.